Matt Mullenweg closed a ticket opened…

Matt Mullenweg closed a ticket opened by Juliette Reinders Folmer about four days ago. The ticket had to do with ending support for PHP 5.6, which was a milestone within the original release scope and is currently the minimum required by WordPress.Β  Juliette proposed ‘bump[ing] the minimum supported PHP version to PHP 7.1.26.” In the comments, Matt explained:

“Just so we don't cherry-pick stats to make a point, it's worth noting that the PHP distribution across all WP sites we track is the same as … in 2018: 85% are 5.6 or above. Only about 66% are 7.1 and above.”

There has been some discussion of this on Twitter, with Andrew Nacin commenting:

“This is _obviously_ a key philosophical decision that should be made by the project lead. And for what it's worth, our philosophies and standards on this have been consistent for more than a decade. The numbers strongly suggest it’s too early to drop PHP 5.6… Last I checked: 25% of sites running WP 5.5 were < PHP 7.1. Way too early to do this.”