PHP versions in WordPress

Alexander Goller notes how WordPress lags behind minimum required PHP versions and offers an explanation:
"Automattic never seemed to have an interest in PHP, the ecosystem or the broader community even though they are the stepping-stone into PHP development for many people."
Although WooCommerce has upped its minimal version to 7.2, Alexander feels it was an overly conservative choice:
"Instead of trying to push the adoption of β€œmodern” PHP, they move to something people are already using. In my opinion, the right move would have been to move to PHP 7.4 now."