PHP 5.6 support to be extended through 2018

PHP has voted on a proposal to extend support for PHP 5.6 — the most recent non-PHP-7 release — through 2018. The vote is a great step for WordPress, as version 5.6 only has about 12% adoption still.

PHP 5.6 support is two fold: activeΒ support and security support. Three options were voted on:

  • 1 year of Active Support (ending Dec 31, 2016), plus 2 years of Security Support (ending Dec 31, 2018).
  • 1 year of Active Support (ending Dec 31, 2016), plus 1 year of Security Support (ending Dec 31, 2017).
  • No change – 8 months of Active Support (ending Aug 28, 2016), plus 1 year of Security Support (ending Aug 28, 2017).

The vote was two part, and was voted on by members of the PHP organization who have voting rights. The first vote was whether to change or not, and change beat no change 42-2. The second vote, whether to extend security support one year or two, was much closer — but successful for the two year option — at 23-21.

The democratic and open voting nature of the PHP community is amazing to me. I don't know that I'd love such a system for the WordPress world, but it's fascinating to see it for PHP. The move extends the previously expected life support for PHP 5.6 by over a year, and that's good for the security of WordPress installations that are likely to use it.

I highly recommend reading the entire outline before the voting segment on the PHP website, as it's a nice looking glass on how PHP development happens.