As Catalin Cimpanu points out, the…

As Catalin Cimpanu points out, the PHP 5.x branch will stop receiving official security updates at the end of this year. As many WordPress developers already know, this branch is still widely used on many servers.

While WordPress recommends 7.2 or greater, it still supports PHP versions as old as 5.2. There has been a “WordPress PHP education initiative” in place (codenamed ServeHappy) for some time, with recent dashboard and plugin notifications planned and possibly appearing in WordPress 5.1.