A critical security update was recently…

A critical security update was recently issued for Duplicator that Wordfence reported as affecting over a million WordPress sites. πŸ”“

Duplicator users should update to version 1.3.28 as soon as possible.

Similar Posts