Google announced recently that they will…

Google announced recently that they will punish “intrusive interstitials” with a ranking penalty in 2017. The article attempts to define what “intrusive” means in this context.

When this news broke, many in the WordPress world turned attention to plugin authors that have plugins that create popups in some form. Most of these authors (including Post Status Partner OptinMonster, for what it's worth) seem confident they aren’t the target of Google’s announcement, as their plugins offer more than popups, and an array of options in addition to immediate execution. However, plenty of site owners abuse these plugins' functionality, so at least this post by Google offers justification for more… user friendly usage.